SEO cho Xenforo phần 3 - Fix url tiếng việt không dấu

Thảo luận trong 'Sưu Tầm & Lưu Trữ' bắt đầu bởi invalid@example.com, 24/11/14.

Khóa đào tạo Khởi nghiệp kinh doanh nhỏ trên internet
Bạn đang tham gia thảo luận tại Diễn Đàn SEO uy tín nhất Việt Nam VNSEOSEM.COM

Đã xem: 170

Trạng thái chủ đề:
Không mở trả lời sau này.
  1. Từ seo xenforo phần 1 và phần 2 chúng ta đã có xong phần meta và robots.txt, bây giờ chúng ta đến với phần url:

    [​IMG]
    Hình ảnh trước và sau khi dùng add-on fix url tiếng việt.

    Lợi ích của việc làm này là làm cho url đẹp hơn, không có chưa từ khóa có dấu, nhằm tăng hiệu quả SEO. (Không dấu luôn được search nhiều hơn, tăng mật độ từ khóa domain keyword)
    Hướng dẫn:
    - Upload các file và thư mục trong thư mục upload lên ngang hàng file index.php
    - AdminCP->Install Addon -> Browse đến file xml -> Install Add-on

    Ngoài ra, nếu bạn không dùng add-on thì có thể áp dụng cách này, truy vấn đến host:

    Bước 1: Các bạn cần có một phần mềm PHP Editor (nên sử dụng Notepad ++)
    Bước 2: Mở file XenForo v1.1.2/library/XenForo/Link.php, trên thanh menu của Notepad ++, các bạn chỉnh Encoding > Encode in UTF-8 without BOM
    Bước 3: Tìm đoạn code sau:


    PHP:

    if ($romanize){
    $title = utf8_romanize(utf8_deaccent($title));
    }

    Bước 4: Thêm vào bên dưới đoạn code sau :

    PHP:

    $aPattern = array ("a" => "á|à|ạ|ả|ã|ă|ắ|ằ|ặ|ẳ|ẵ|â|ấ|ầ|ậ|ẩ|ẫ|Á|À|Ạ|Ả|Ã|Ă|Ắ|Ằ|Ặ|Ẳ|Ẵ|Â|Ấ|Ầ|Ậ|Ẩ|Ẫ",
    "o" => "ó|ò|ọ|ỏ|õ|ô|ố|ồ|ộ|ổ|ỗ|ơ|ớ|ờ|ợ|ở|ỡ|Ó|Ò|Ọ|Ỏ|Õ|Ô|Ố|Ồ|Ộ|Ổ|Ỗ|Ơ|Ớ|Ờ|Ợ|Ở|Ỡ",
    "e" => "é|è|ẹ|ẻ|ẽ|ê|ế|ề|ệ|ể|ễ|É|È|Ẹ|Ẻ|Ẽ|Ê|Ế|Ề|Ệ|Ể|Ễ",
    "u" => "ú|ù|ụ|ủ|ũ|ư|ứ|ừ|ự|ử|ữ|Ú|Ù|Ụ|Ủ|Ũ|Ư|Ứ|Ừ|Ự|Ử|Ữ",
    "i" => "í|ì|ị|ỉ|ĩ|Í|Ì|Ị|Ỉ|Ĩ",
    "y" => "ý|ỳ|ỵ|ỷ|ỹ|Ý|Ỳ|Ỵ|Ỷ|Ỹ",
    "d" => "đ|Đ",
    );
    while(list($key,$value) = each($aPattern))
    {
    $title = @ereg_replace($value, $key, $title);
    }

    Thế là xong phần url, nhưng còn một vấn đề nữa, bạn cần phải khắc phục, cho những ai không rành về xenforo, thường thì khi setup xong thì xảy ra vấn đề url có dạng index? ở sau: domain.com. Cách fix rất đơn giản, vào Admin --> Option--> Search Engine Optimization --> Use Full Friendly URLs -> Tích chọn, Save.
     
    Đang tải...
    nam lim xanh

    Bình Luận Bằng Facebook

Trạng thái chủ đề:
Không mở trả lời sau này.

Chia sẻ trang này